Airsoft Canada
https://blackblitzairsoft.myshopify.com/

Go Back   Airsoft Canada > Discussion > Doctor's Corner
Home Forums Register Gallery FAQ Calendar
Retailers Community News/Info International Retailers IRC Today's Posts

Sig 552 Electrical/trigger problem *SOLVED*

:

Doctor's Corner

Reply
 
Thread Tools
Old November 9th, 2009, 23:54   #1
dubious
 
Join Date: Jun 2009
Sig 552 Electrical/trigger problem *SOLVED*

Not sure what brand this gun is, my friend bought it a Cabellas here in winnipeg. It worked very well for a long time, and then all of the sudden it started blowing fuses. It would work for a bit on a new fuse (shooting normally), then it would blow again. We tried bigger fuses--same deal. Then it just stopped working altogether. I have it all apart, the wiring, motor, and battery are fine. Is there something in the trigger mechanism of the mechbox that could cause a problem like this?

Aside: anyone know what version mechbox goes in a Sig? replacements seem pretty hard to come by.

Thanks!

Last edited by dubious; November 20th, 2009 at 19:43..
dubious is offline   Reply With Quote
Old November 10th, 2009, 00:05   #2
Con Murder
 
Con Murder's Avatar
 
Join Date: May 2009
Location: Lethbridge Alberta Canada
The mechbox is V3 and it is made by cybergun (a cloner rebrand JG). Most fuse problems occur from a short in the circiut, check for nicks in the wires, then ensure the connectors are fine. It may be a locked mech box and if so you could tell by the piston being cocked back instead of sitting forward. Trip the anti reverse latch and it be fixed. If none of these are solutions for you then wait for more responses.

PS if you need a tutor for it Mechbox.com ids where to find a how-to
__________________
Con Murder
Dark Rhino
L.A. Airsoft
Con Murder is offline   Reply With Quote
Old November 10th, 2009, 00:10   #3
etd
 
etd's Avatar
 
Join Date: May 2008
Location: North Bay, Ontario
The wiring in the stock sig 552 is crap. I've had the same problem. Just re-wired the thing and it was back up and running. I'd say chances are the wiring is the issue even IF its not exposed. If you upgraded to a 9.6 or higher I'd bet my life on it.
__________________
etd/Carmelo - Team North Bay
v3 Aeg specialist
etd is offline   Reply With Quote
Old November 10th, 2009, 00:14   #4
dubious
 
Join Date: Jun 2009
Thanks for the fast reply! The piston was locked back when i took the gun apart (which of course I remedied). I realize i also forgot to mention that I dry fired the gun using all of the regular connectors and wiring, just jumpering the input/output sides of the trigger, and it worked just fine, so I am still inclined to think that the problem is in the trigger.
dubious is offline   Reply With Quote
Old November 10th, 2009, 04:13   #5
etd
 
etd's Avatar
 
Join Date: May 2008
Location: North Bay, Ontario
Well if thats the case I'd try getting a new v3 switch but up I'm stumped....
__________________
etd/Carmelo - Team North Bay
v3 Aeg specialist
etd is offline   Reply With Quote
Old November 10th, 2009, 05:25   #6
Con Murder
 
Con Murder's Avatar
 
Join Date: May 2009
Location: Lethbridge Alberta Canada
Check the switch and ensure that when the trigger is pulled the male end coontacts the female end on both sides. Otherwise replace.
__________________
Con Murder
Dark Rhino
L.A. Airsoft
Con Murder is offline   Reply With Quote
Old November 12th, 2009, 17:43   #7
locprecision
 
Join Date: Jul 2009
Usually the trigger contacts are pitted and/or dirty. I usually fix this by sanding the contacts to clean them. Hope this helps.
locprecision is offline   Reply With Quote
Old November 14th, 2009, 13:03   #8
jeanparmesan
 
jeanparmesan's Avatar
 
Join Date: Jun 2009
Location: Winnipeg, MB
that's my gun! swiss arms sig 552.
jeanparmesan is offline   Reply With Quote
Old November 17th, 2009, 23:16   #9
dubious
 
Join Date: Jun 2009
Alright, so I got the mechbox all apart, took apart the trigger mechanism and found a piece of melted plastic in one of the contacts. Chipped it off, greased everything, put it back together and now it only shoots on semi. Any ideas as to what I did wrong?
dubious is offline   Reply With Quote
Old November 17th, 2009, 23:18   #10
Styrak
 
Styrak's Avatar
 
Join Date: Jan 2007
Location: Saskatoon, SK
Send a message via MSN to Styrak
Cut off lever, selector plate, or selector plate/cutoff lever spring.
__________________

Airsoft Sales and Repair/Upgrade Services
Styrak is offline   Reply With Quote
Old November 17th, 2009, 23:20   #11
dubious
 
Join Date: Jun 2009
Is the cut off lever the contact that opens and closes in semi and stays together on auto? If so, is there a spring that's supposed to hold it closed?
dubious is offline   Reply With Quote
Old November 17th, 2009, 23:45   #12
Styrak
 
Styrak's Avatar
 
Join Date: Jan 2007
Location: Saskatoon, SK
Send a message via MSN to Styrak
There's a spring on the outside of the mechbox that connects the selector plate to the cutoff lever. Is it missing?
__________________

Airsoft Sales and Repair/Upgrade Services
Styrak is offline   Reply With Quote
Old November 17th, 2009, 23:50   #13
dubious
 
Join Date: Jun 2009
ah. did some research, now I know what the hell you're talking about All of the springs seem to be doing what they should be. maybe I'll just try ptting it back together again.
dubious is offline   Reply With Quote
Old November 17th, 2009, 23:59   #14
Styrak
 
Styrak's Avatar
 
Join Date: Jan 2007
Location: Saskatoon, SK
Send a message via MSN to Styrak
Alrighty. Try that and post again if you have trouble
__________________

Airsoft Sales and Repair/Upgrade Services
Styrak is offline   Reply With Quote
Old November 18th, 2009, 00:28   #15
dubious
 
Join Date: Jun 2009
balls. No dice, same thing as before. That's enough frustration for one night. Thanks for your help!
dubious is offline   Reply With Quote
ReplyTop


Go Back   Airsoft Canada > Discussion > Doctor's Corner

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Airsoft Canada
https://blackblitzairsoft.myshopify.com/

All times are GMT -4. The time now is 07:28.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.