Airsoft Canada
BuyAirsoft

Go Back   Airsoft Canada > Discussion > Doctor's Corner
Home Forums Register Gallery FAQ Calendar
Retailers Community News/Info International Retailers IRC Today's Posts

MP5 Mechbox unwinding ->lockup

:

Doctor's Corner

Reply
 
Thread Tools
Old December 13th, 2006, 14:06   #1
Corey Darling
 
Join Date: Mar 2005
MP5 Mechbox unwinding ->lockup

Hello

I posted a week or two ago concerning my recently upgraded MP5.

http://www.airsoftcanada.com/showthread.php?t=31667

After that upgrade - pdi 150%, torque up gears, bushings, shims, metal bb spring guide. - I decided to order a new Guarder Nozzel and Tappet Plate.

With my new found confidence in upgrading my mp5, i figured that changing 2 parts would be a sinch.

Well, Got it all back together, didnt touch anything else to my knowledge, and it wouldnt shoot the bb's the mag pushed into the chamber. I figured it was something to do with the new guarder tappet plate, or my hopup got messed up while reassembling the gun. (maybe my barrel moved in/out of the hopup unit?)

It would fire if i inverted the gun, removed the mag, and shot in single. Then i could insert a mag, and fire on full auto/semi np, although it didnt sound quite right/not the same power as before.

So i tore the gun apart again. and after reading that somepeople has to dremmle down their tappet plates, i decided to compare the gaurder to the stock.

The guarder is far wider at the tab portion where the half gear engages it. (looking from top down, its wider.)

So i put my stock tappet in but kept the guarder nozzel to narrow down the problem.

Well. Put it back together, checked timing to be "locked and at 1 oclock".

Fired and Voila! it worked, for about 10 shots before the Mechbox started to unwind, and with more trigger pulls, the whole gun eventually locked up.

Tore it apart again. The piston was cocked right back. :S Opened very carefully and let it unwind.

So for the next 3 or 4 attempts (build up, test, breakdown again), my friend and i tried to figure out what was going on with these gears.

We tried multiple timeings (half gear pin at 3-even 4 oclock) with the latch locked each time.

Still same problem. I then placed the original nozzel back in. No change.

Now instead of cocking the pistion right back and locking up, it cocks half way, and locks up. i also found this pins the tappet and nozzle right back also at the same instant. all 3 will stay that way untl i opened the case.

Any idea what is going on here? I had this gun working great a few days ago, then i change 2 parts and all of a sudden i cant get the thing to shoot. Im now on my 5th or 6th attempt, having stripped 2 of the screw locations on the top of the mech box already from tightening and loosing so much lol.

Any ideas would be much appreciated as to how to properly set this timing thing up, if that is infact the issue.

We figured the anti reversal latch wasnt locking with the grove on the bevel at the right instant, causing the whole thing to wind back and lock with the pistion just as it starts to decompress.

my dad is bringing back a p90 for me in the next few days from asia, so this mp5 will become my upgrade learning gun, im not going to touch that p90 lol, maybe except for metal bodies

Thanks

Corey

Last edited by Corey Darling; December 13th, 2006 at 14:11..
Corey Darling is offline   Reply With Quote
Old December 13th, 2006, 15:05   #2
Corey Darling
 
Join Date: Mar 2005
Tried again, same thing

to unstress the spring though, i used some needlenose plyers and pulled on the reversal latch. this unwound the system

im able to turn my bevel gear by turning its bushings, and found that the latch isnt even engaging with the groves on the bevel gear. i can feel the latch pass over, but when i turn in the opposite direction, it doesnt lock up, just clicks over the top of the grove and continues on.

Could all of this gear timing stuff be caused by the antireversal latch not working properly?

It seems to be working on and off. I can turn the bevel until the sector starts to pull the tappet plate back, then i turn a bit further and release the bevel, sometimes it catches the reversal latch, sometimes not.

is there anyway i can get its spring to tighten up a bit so it has the strength to engage with the bevel gear?

thanks

corey

Last edited by Corey Darling; December 13th, 2006 at 15:14..
Corey Darling is offline   Reply With Quote
Old December 13th, 2006, 15:35   #3
Mud Gunner
 
Mud Gunner's Avatar
 
Join Date: Sep 2004
Location: Edmonton
Send a message via MSN to Mud Gunner Send a message via Yahoo to Mud Gunner
Maybe time for new anti reversal latch spring?
__________________
Proud owner of a pile of airsoft guns and kit with the credit card bills to prove it!
Mud Gunner is offline   Reply With Quote
Old December 13th, 2006, 15:51   #4
Corey Darling
 
Join Date: Mar 2005
yeah, but anyway to stretch this one out again? ill give it a try but if someone has experience with how well that works that woould be great. id hate to pay 25 bucks shipping for a 2 cent spring
Corey Darling is offline   Reply With Quote
Old December 13th, 2006, 15:53   #5
BloodSport
Traveling Man
 
BloodSport's Avatar
 
Join Date: Aug 2001
Location: Moose Jaw, Saskatchewan
better $25 for a 2 cent spring, then $80 for new gears......
__________________
Saskatchewan Age Verifier! Contact for more Info.
BloodSport is offline   Reply With Quote
Old December 13th, 2006, 15:56   #6
Corey Darling
 
Join Date: Mar 2005
cant beat that logic lol
Corey Darling is offline   Reply With Quote
Old December 13th, 2006, 17:11   #7
Corey Darling
 
Join Date: Mar 2005
Problem still exists

Tried stretching the spring by bending back the end of spring that presses up againest the mechbox. definately helped push the latch in place while i was spining the gears by hand.

but once i got the receiver back on and test fired, the pistion immediately locks up half way, and sometimes all the way back :S at best i can get 1 shot out on semi-auto before the thing starts to lock up. with every trigger pull is gets worse and worse till nothing moves

any tips on why this is occuring? i though it could have been the reversal latch, but i think thats corrected now.

I've read that somepeople believe in gear timing, other dont. at this point im willing to try anything.

i've been dry firing the gun, with only the receiver attached to hold to motor on so i can see the nozzle and piston move in the cylinder vent.

Last edited by Corey Darling; December 13th, 2006 at 17:13..
Corey Darling is offline   Reply With Quote
Old December 13th, 2006, 17:24   #8
CDN_Stalker
Official ASC Bladesmith
 
CDN_Stalker's Avatar
 
Join Date: Jul 2003
Location: Ottawa, Ont.
Send a message via MSN to CDN_Stalker
I found my MP5 would have it's anti-reversal latch overrun (unwound when I'd stop shooting) when I bought a second PDI 150% spring and found it too long (6 5/8") and stiff compared to my original one. I cut off a few coils, installed it, the gears and piston would unwind after every few shots. I took the spring out, threw it as far as I could (waste of $20) and put my good 150% back in. Haven't had the problem since. Remember my pressuring you to get rid of that spring and buy a good (NON-PDI) spring that went through quality control? See why now?

Last edited by CDN_Stalker; December 13th, 2006 at 17:27..
CDN_Stalker is offline   Reply With Quote
Old December 13th, 2006, 17:31   #9
Corey Darling
 
Join Date: Mar 2005
lol

yeah i know I did measure it like you suggested and its the long one - shiney black.

whats bugging me though is that it was working well before i tore it apart the second time to put in the tappet and nozzel. :S

i ran about 20 low cap mags through it before i put them in and didnt have any issues like this.

doesnt make sense

corey

Last edited by Corey Darling; December 13th, 2006 at 17:33..
Corey Darling is offline   Reply With Quote
Old December 13th, 2006, 17:46   #10
Corey Darling
 
Join Date: Mar 2005
how are guarder springs? or do you guys recommend systema? thx
Corey Darling is offline   Reply With Quote
Old December 13th, 2006, 18:44   #11
ILLusion
GBB Whisperer
 
ILLusion's Avatar
 
Join Date: Jun 2002
Location: Toronto
Just a wild idea, but are you for sure your battery is fully charged?
ILLusion is offline   Reply With Quote
Old December 13th, 2006, 19:06   #12
Corey Darling
 
Join Date: Mar 2005
hum.....

well, i charged it last night before i took it apart the first time. havent charged it since. ive had it apart and backtogether about 10 times now lol, getting old. ill be able to do this blind folded soon.

ill give it a quick zap when i get off work, dont have the charger with me right now lol

Corey
Corey Darling is offline   Reply With Quote
Old December 13th, 2006, 20:28   #13
CDN_Stalker
Official ASC Bladesmith
 
CDN_Stalker's Avatar
 
Join Date: Jul 2003
Location: Ottawa, Ont.
Send a message via MSN to CDN_Stalker
I've had really good experience with the Prometheus springs, they compress alot easier than my GOOD PDI 150% spring, and still put out well. Depending on your goal fps, as well as what other upgrades you want to put in, I'd recommend the Prometheus 110SP, in a relatively bone stock MP5, it should give you around 330-340fps. Add in a bearing spring guide and tightbore barrel, that should set you around 350-360fps, more than enough for outdoor games using 0.25g BBs.
CDN_Stalker is offline   Reply With Quote
Old December 13th, 2006, 20:54   #14
Guardian
 
Guardian's Avatar
 
Join Date: Aug 2004
Location: Ajax-Pickering (GTA)
Does the gun work with the stock spring in? If it does I would stop mucking with the anti-reversal latch and try a new spring...
__________________


"Sex is one of the 9 reasons for reincarnation, the other 8 are unimportant." Henry Miller

Guardian’s airsoft projects @ http://www3.sympatico.ca/aftershock/
Guardian is offline   Reply With Quote
Old December 13th, 2006, 21:39   #15
Corey Darling
 
Join Date: Mar 2005
Hey Guardian

I was just thinking that, so i went home and grabbed the stock spring to try.
I also charged my battery.. turns out that is took about 550 mA ! its a 600mA battery, so it was pretty dead which really surprised me.

Thanks for the info Stalker, ill give that one a try. I do have the metal spring guide, torque gears... so that combo should go pretty good from what ive read

Im going to try one last time with my crap pdi 150 spring with my recharged battery and see if i can get this thing to crank over. if not, ill try my stock spring

will get back to you soon

Corey
Corey Darling is offline   Reply With Quote
ReplyTop


Go Back   Airsoft Canada > Discussion > Doctor's Corner

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Airsoft Canada
BuyAirsoft

All times are GMT -4. The time now is 07:35.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.